Property Inspector Help

Utility for filtering, searching, sorting and editing VI properties and metrics from the project
Version 3.1, November 2019, © 2013 - 2019 ABCDEF. All rights reserved.
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Property Inspector Overview

Property Inspector is a powerful utility for viewing, searching, sorting and editing VI properties of all Vis in a project, class
or library. All project items can be filtered by 20 categories allowing only relevant items to be visible. It allows searching
all the items based on 44 VI properties including VI Description, Data Size and Allow Debugging. Some properties cannot
be displayed in LabVIEW including Clones, Date Modified, Execution Status, In Memory, Inline is Allowed and Modified.
After selecting all or some of the results, 23 of the 44 specified VI properties can be edited for all Vis in a single click.
Powerful string manipulation functions allow for the entire field to be searched, edited, replaced or removed. For
example, all Vis base on a VI template with the default description like “Use this template to “ can be quickly searched,
selected and then the entire description removed. It is also possible to modify a different VI property than the one
searched.

Property Inspector supports many search criteria that are not allowed by LabVIEW, like finding any value, a missing value,
comparing a value against a threshold, or finding a value of True or False. Search Description for blank identifies Vis that
need documentation. Search LV Version for Less Than the current version will show all older code. Search Execution Status
Equals ‘bad’ shows all broken code. Search Reentrant is True followed by Search In with Reentrancy Type Contains ‘Pre’
shows all Vis with Preallocated Reentrancy. Searching a single property by True can quickly isolate all Vis with Allow
Debugging, Auto Error Handling or Modified status. Easily disable Allow Debugging on hundreds of VIs, compare the
performance of your program, and then turn it back on.

Flexible edit modes allow replacing a string with an empty value, replacing the whole string and not just the match, or
removing a path value by replacing it with Not-A-Path. Sorting all VIs by value would identify VIs with the highest Data Size,
Code Size or Revision Number. Unlike VI Profiler, the Data Size shows the memory used before the VI is executed and
would identify static data saved in the front panel or block diagram.

Selected search results can all be edited, deleted, opened or run in a single operation. One click can show the block
diagrams of all Vs or select them in the Project Explorer. All opened windows can be closed with a single operation. The
visible details in the results window can be exported to a spreadsheet file for additional analysis or documentation. The
settings can enable all elements by 17 object types and which of the 42 VI properties are displayed, allowing just the items
of interest to be shown.

Three new features in Version 3 are Global Exclusion™, Persistent Selection™ and Compound Sorting™. Searching the
category ALL with a mode of Exclude allows a quick way to remove a specific set of items from the search. Persistent
Selection™ maintains the selection of all items in the window after changing Object Filters, Search or Sort settings. Every
sort operation can be based on the previous sort results, allowing for Compound Sorting™. For example, sort by data
ascending to see the oldest object. Then click to sort by object type and quickly see the oldest of each type.

Powerful VI Scripting is included using the standard interfaces for VI Analyzer and Quick-Drop Plugins. This allows complex
operations to be performed on some or all Vis with just a small amount of your own code. Leveraging the existing library
of Community Quick-Drop Keyboard Plugins speeds the execution of standard operations like Align front panel controls to
connector pane pattern or Move block diagram contents to origin. VI Scripts can also be used to select project items using
custom criteria.

The utility keeps a history of the last 9 Search operations and each can be repeated in a single click. Disabling Search on
Select allows editing the criteria before searching or compounded with Search In. This history can also be cleared.

It optionally includes all targets found in the project including cRIO and FPGA targets. Another option will include all
dependencies shown in the project.

The utility can be found under the Tools menu -> ABCDEF -> Property Inspector...
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https://decibel.ni.com/content/docs/DOC-9573
https://decibel.ni.com/content/docs/DOC-13623
https://decibel.ni.com/content/docs/DOC-13623
https://decibel.ni.com/content/docs/DOC-30150

Installation Requirements

Compatible LabVIEW Versions: >= 2014.

Tested LabVIEW Versions: 2014, 2015, 2016, 2017, 2018 and 2019
Compatible OS Versions: Windows, Mac.

Hardware Requirements: None

Both LabVIEW and VIPM must be running as Administrator to install

LabVIEW must be restarted after installation.
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Toolbar

& 7O «»
E % 2

Open  Settings Filter on OpenVl Refresh  Back Mext
Project

Buttons on the toolbar speed operation of common functions. Some buttons are disabled if they don’t apply to the
selection or can’t be used during the current operation.

Open Project button
Press the Open Project button to browse for the project file to open. The project file cannot be newer than the current
LabVIEW version. If the project is older than the current version, any Vls edited would be updated to the current version.

Settings button
Opens the settings dialog. Options include the project object types, columns to display, search options, edit options and
column sorting.

Filter on button
When a filter is applied, the Filter on button turns on. Click the filter on button to disable the filter and see the unfiltered
results.

Open VI

When one or more VIs are selected, this button will open all VI front panels. Holding the control key will show the block
diagrams instead by minimizing the front panels. Use the Window->Close opened windows to close them automatically.
Double-clicking a single item in the results window opens the front panel and holding control opens the block diagram.

Refresh
When one or more VIs are selected, this button redraws the results for the selected row(s).

Back
Moves the selection one row higher in the results table. This button is only enabled if a result item is selected except the
last one.

Next
Moves the selection one row lower in the results table. This button is only enabled if a result item is selected except the
first one.
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Search Parameters

Search | Description Iz‘ Excludes Iz‘ ABCDEF | Search || Search In |
Edit Mode | Append [+] = _
Edit Text | Written by Michael Munroe Edit Selected
ABCDEF 800-422-1523 -

Use the search parameters section to specify the properties or metrics to search by, the type of comparison and the value
to display. Use the Edit Mode and Edit Text to change the value of the selected results.

Search drop-down
Use this drop-down to select the VI property to search. Choices include:

Name Description Editable | Notes
ALL Combines all string properties to No Compare options are Contains and Excludes
simplify searching and excluding
Allow Debugging VI Property found under Execution Yes
Auto Error VI Property found under Execution Yes
Handling
Block Diagram VI Metric found under Memory Usage No
Size
Callers Hidden property visible by selecting No
View->Browse Relationships->This VI's
Callers and then counting the Vls
shown
Class Shown in the hierarchy of the project No
Clones Hidden property No Found by searching reentrant Vls in
memory
Code Complexity Shows the complexity factor used when | No Set
compiled
Code Size VI Metric found under Memory Usage No May show as 0 if Separate Code from
Source is ON and the Vi is not in memory
Data Size VI Metric found under Memory Usage No
Date Modified File system property found on the disk No Enter a date in mm/dd/yy format and use
Greater or Less Than. Just enter a year
(2000 and later) and Less Than will use 1/1
and Greater Than 12/31
Description VI Property found under Yes
Documentation
Execution Priority | VI Property found under Execution Yes Includes background (0), normal, above
normal, high priority, time critical and sub-
routine (5). Enter the first letteror0to 5
to edit the value
Execution State VI State indicated by a broken run No Includes invalid, idle, running, bad, run top
arrow level
File Size VI Metric shown under Memory Usage | No Size of the VI file, LLB or library file
Front Panel Size VI Metric found under Memory Usage No
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History Text VI Property found under General, Yes Can only be cleared (remove)
Revision History...

In Memory VI Metric found by searching memory No
for each VI

Item Name VI Property as shown in the project No
window

Inline is Allowed Hidden property No Shows if Inline SubVI can be set to true

Inline SubVI VI Property found under Execution Yes Allowed only if debugging is false and
reentrant is set to pre-allocate

Iltem Path VI Property as shown in the Files display | No

under the project. This path is relative
to the project folder unless the item is
outside the project folder

Iltem Type VI Property indicating the item type No

(Control VI, Standard VI, Global VI,
Folder, etc.)
Library Shown in the hierarchy of the project No
Logging File Path Used with Operate -> Data Logging Yes
LV Version VI Property found under General No
(Source version)

Modified Hidden property shown when closing Yes Modified only by saving
the project

Monitor VI Property found under Window Run- | Yes 0 =Primary, 1 or 2 sets the specific monitor
Time Pos

Preferred VI Property found Execution, Preferred | Yes Includes user interface, standard,

Execution System | Execution System instrument 1/0, data acquisition, other 1,
other 2, same as caller. Use the first 4
letters to edit the value or 1, 2 for other

Protection VI Property found under Protection Yes

Reentrant VI Property found under Execution Yes

Reentrancy Type VI Property found under Execution Yes

(Shared or Prealloc)

Revision Number | VI Property found under General Yes Remove to set to zero. When writing this
property, only replace with a value greater
than the current revision number.

Run Time Menu Setting found under Edit->Run-Time Yes

Menu...
Same as VI Name | VI Property found under Window Yes
Appearance

Scan Time Time to scan the object’s properties No In milliseconds

Separate Comp. VI Property found under General Yes

Code (Separate compiled code from source

file
Show front panel VI Property found under Window Yes

when called

Appearance, Customize
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Show front panel VI Property found under Window Yes
when Loaded Appearance, Customize
Show Menu Bar VI Property found under Window YES
Appearance, Customize
Suspend when VI Property found under the Operate Yes
Called menu
Target VI Property displayed in the bottom left | No Typical values are My Computer, cRIO-xxxx

name

corner of each VI after the project

or FPGA

Total Data Size

VI Metric shown under Memory Usage | No

values
Transparency VI Property found under Window Yes 0 to disable, 100 is completely transparent
Appearance, Customize
Window Behavior | VI Property found under Window Yes Values include default, floating, floating-
Appearance, Customize hidden and Modal
Window Title VI Property found under Window Yes Set Same as VI Name to False before

Appearance

setting

Compare Modes
Use this drop- to specify the comparison method. Text match case is an option specified in the settings.

String

Equals Includes results where the property or metric equals the specified string
value

Contains Includes results where the property or metric contains the specified
string value. This mode supports the special characters: .*?5"\

Excludes Includes results where the property or metric excludes the specified
string value. This mode supports the special characters: .*?5"\

Starts With Includes results where the property or metric starts with the specified
string value

Ends With Includes results where the property or metric ends with the specified

string value

Binary/String

Is
Blank/0O/False

Includes results where the property or metricis a blank string ora 0
value. This includes settings that are False.

Not Includes results where the property or metric is not blank string or a not
Blank/True a 0 value. This includes settings that are True.
Numeric Less Than Includes results where the Metric is less than the specified value. Strings
are compared character by character.
Greater Than Includes results where the Metric is greater than the specified value.

Strings are compared character by character.
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Value Field
Enter the value to search for or to filter out. Enter the text to include or exclude from the results.

String Enter text Enter the text to include or exclude from the results.
Binary/String | 1/T/Y/0/F/N Enteral, TorY for trueand a0, F or N for false.
Numeric Enter number Enter the number to compare. Metric syntax is allowed including

K for 1,024 and M for 1,048,576. All value are integer except
LabVIEW version, which returns a decimal digit (i.e. 8.6).

Special Reentrancy Type Enter 0 or S for Shared or 1 or P for Pre-allocate

Search Button
Applies the search criteria to the entire project and displays the filtered results. This also sets the Filter On button.

Search In Button
Applies the search criteria to the displayed results window and displays the combined search results. This also sets the
Filter On button. There is no limit to the number of combined searches.

Edit Mode
Enter the how the edit is to be applied to the selected Search item. Note that it is possible to change the Search item and
edit a different property than was used to filter the results window.

Match Replaces the part of the property that matches the filter by value with the edit text, same
as replace for binary settings

Prepend Inserts the edit text to the start of the filter by property, same as replace for binary
settings

Append Appends the edit text to the end of the filter by property, same as replace for binary
settings

Replace Replaces the entire property with the contents of the edit text, or True or False, orOor 1

Remove Removes the entire property contents and leaves the field empty, false or Not-A-Path
value

Edit Text

Enter the text to edit the property. If the Edit Text box is disabled, selected search property is not editable. A multi-line
string can be entered by pressing Control-Enter, or changing the settings to show slash codes (i.e. /r/n)

Edit Selected Button
Applies the Edit Mode to the Search property, optionally using the Edit Text and the Value Field
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Results Table

Itemn Name Item Type Exec State  Description InMem Debug Auto Err Date Modified Code Size  Data Size FP Size
Test Awi Standard VI | Idle Test a basic DAQ board image. 0 1 1 12/19/2012 3:00 PM  10.36k 141,82k 4.06k
Test Bvi Standard VI Idle Test an elite DAQ board image. 0 1 1 12/19/2012 %00 PM 462k 13852k  4.06k
Test Cowi Standard VI Idle Test a GPIB board image. 0 1 1 12/19/2012 3:00 PM 13,22k 14348k 4.06k
Test_Common Te All Boards.vi Standard VI Idle Image check for blocks that are commont 0 1 1 12/198/2012 9:00 PM 758k 474k 4.06k
Get Test Mame.vi Standard VI Idle Build a test name from the board type and 0 1 1 12/19/2012 900 PM 214k 1.25k 4,75k
Test Boards_TASK.vi Standard VI  Idle See <b>Read_Me.html</b> in the <b>Boi 0 1 1 12/19/2012 %00 PM 934k 287k 6.88k
Beoard Design.lvclass LVClass Base class for all board types. 1 0 0 12/19/2012 9:00 PM 0 0 0
Component Orientation and Positi Control VI 1 0 0 12/19/2012 3:00 PM 0 0 5.76k

This table shows the project items flattened into a row format with the details separated by columns. Use the settings
dialog to select which columns to display. The columns can optionally be sorted by the property name ascending or
descending. The column widths can be adjusted by dragging the dividers. Double-click a VI in the results table to open it.

When the Filter On button is selected, the results table shows the filtered results. To edit VI properties, enter the change
into the Edit Text box, select the rows in the table to change and press the Edit Selected button. Note that the editing the
results table does not edit the VI properties in the VI.

Click on a column header to sort the results by the selected parameter. Click the same column to reverse the sort order.
These sorting options can also be selected by the View menu.

Status Bar
‘ | |

| Mo Selections 54 items displayed (4.2 sec) Board Testing.lvproj (Wer. 12.0)

The status bar at the bottom of the window shows the current details of the project and the utility.

The left one-third shows the status of the toolbar and the Search Parameters. Messages include ‘Initializing’, ‘Opening’,
‘Ready’, ‘Searching’, ‘Replacing’, ‘No Items’, ‘No Results’, ‘No Selections’, ‘Enter O, F, 1, or T’, ‘Enter Edit Text’, “Enter year
or date (mm/dd/yy)”, ‘Enter Current password’ and ‘Enter New Password’. If the status shows ‘Cannot edit ????’, then the
Search property is not editable. This is common for all VI metrics. Select a different property to search by or perform an
edit operation. After performing a search, this box will show the exact criteria of the search.

If the status is ‘No Selections’, one or more results must be selected for the edit operation.

The middle one-third shows the details of the selections in the results window. It shows total number of items in the
project, number of items in the filtered results (with percentage), number of items selected and the name of the item if
only one is selected. Some operations include the total time to complete the operation.

The right one-third shows the name of the selected project and its saved LabVIEW version.
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Menu Bar

mﬁclit View Operate History Window Help

The menu bar includes several operations that are also on the toolbar, and several that only on the menu. Shortcut keys
are shown by underlines, just like in the menu. Hold the Alt key to use the shortcuts. Control shortcuts are available for
some menu items shown with the (*) symbol. Items in parenthesis are replaced by the actual content described.

File Menu Open Project ... (*0) Browses for a LabVIEW project file to load. An error shows if the Project file
is newer than the current LabVIEW version.
Open LVLib ... Browses for a LabVIEW library file to load (.LVLib).
Open LVClass Browses for a LabVIEW class file to load (.LVClass).
Reload Project Reloads the currently opened project to synchronize all items
Close All Closes the current project, library or class
Save Selected Saves the selected items
Save All Saves all the items in the results window
Export Results Exports the filtered results window to a spreadsheet file
Exit (*Q) Exits the utility and closes the open project
Edit Menu Select All (*A) Selects all rows of the results window
Deselect All (D) Deselects all results
Invert Selection (") Inverts the selection. Selects all results that are not selected and deselects
all results that are
Delete Selected VIs Deletes the selected Vis from the project. A confirmation dialog asks if Vis
(~X) in auto-populating folders should be deleted from disk.
Open Script Template Opens a sample Script Template VI for creating custom scripts using the VI
Reference. The connector pane must not be modified.
Select Script File Selects a custom Script File to run
Run VI Script (V) Run the custom Script File on the selected items
Update Selections on When checked, only the VI Scripts that return a failure will remain selected
Failure
Open QD Script Opens a sample QD Script Template VI for creating custom scripts using the
Template VI Reference. The connector pane must not be modified.
Select QD Script File Selects a custom QD Script File to run
Run QD Script (*R) Run the custom QD Script File on the selected items
View Menu Sort By Select the property column to sort by. Clicking the column header will also
change the sort by setting. Select Unsorted to revert back to project order.
Ascending When checked, the sort is ascending and unchecked is descending
Show VIs in Project Selects all Vs selected in the Pl window in the LabVIEW Project window
Compound Sorting When checked, each sort starts with the previous sort results. If unchecked,
each sort starts with the project order
Operate Open Vls Opens the selected Vis and controls
Menu Open Block Diagrams Opens the block diagrams of the selected VIs by minimizing the front panels
Run Vis Opens and runs the selected Vls
History (History list) This menu provides a quick and easy way to perform repetitive operation
Menu on several projects or Vis. This list keeps a history of the last 9 operations.
This list is stored on disk and kept for every use. Duplicates are filtered out.
If only No History is shown, then there is no history.
Clear History This clears the list of history items
Search on Select (*0) To speed repetitive operations, checking this option will perform the search
on the history selection immediately. Disable to perform Search In results.
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Window (Opened files) This menu shows all the opened ViIs.
Menu (Opened projects) This section of the menu shows all the opened projects
Close Opened If a large number of items are opened by the Open VIs function, this menu
Windows item will close them all at once. This option is only available when windows
have been opened by the utility
Show Edit Error Dialog | Displays the error dialog containing previous edit errors
Help Menu Show Help (F1) Opens the help document (this one)

Online Support and
Resources

Opens the product support webpage

YouTube Videos

Opens a page with demonstration videos of the utility

Search Examples

Loads examples shown below into the search and edit criteria

Alliance Member Page

Opens the NI Alliance Member directory page for ABCDEF

Product Homepage

Opens the product page at abcdef.biz

LabVIEW Tools
Network

Opens the product page on the LabVIEW Tools Network

Community Quick Drop
Keyboard Shortcuts

Opens the NI forum page listing the latest Quick Drop Plugins

About Property
Inspector

Displays the version number of the utility
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Settings
The settings window allows control of project object types to include, columns to display, filter options, edit options and
column sorting.

3 Edit Settings x

Object Types

Standard ¥l
Control VI
Control - Typedef
Control - Strict TD
Global VI

Class Private Data
Property Definition
Class

Library

[+] XControl
Polymorphic VI
Malleable Vis
Configuration VI
DACmx

Variable

Folder

Document
Run-time Menu

Columns to Display

Target

[tem Mame

ltern Type

[tem Path

Library

Class

Window Title

Same as V| Mame
Execution State
Description

LY Version

In Memory

Allow Debugging
Auto Error Handling
Date Modified
Modified

Separate Comp. Code
Show FP when Called

Revision Number
History Text
Protection

Code Size

Data Size

Front Panel Size
Block Diagram Size
Total Data Size
File Size

Code Complexity
Reentrant
Reentrancy Type
Clones

Callers

Inline subVl
Inline is Allowed
Transparency
Logging Path

Search Options

[] Match Case
[ Incl. Dependencies
[ Incl. Targets

Edit Options

Save Change
Close [tern

Trim Description
[ ] Use "' Codes

Sort Column Mames
:._’,.I' Mo Sort

Images Show FP when Loaded Show Menu Bar
Other Suspend when Called Run Time Menu
Preferred Exec System Monitor
Execution Priority Scan Time
o oK |w Cancel
Object Types

Select the different types of project items to show in the results window. Types include Standard VI, Control VI, Control —
Typedef, Control — Strict TD, Global VI, Class Private Data, Property Definition, Class, Library, XControl, Polymorphic VI,
Malleable Vis, Configuration VI, DAQmx, Variable, Folder, Document, Run-time Menu, Images and other items. Changes to
Object Types will be applied immediately.

Columns to Display

Select the VI property and VI metrics to show in the results window. Items include Target, ltem Name, Item Type, Item
Path, Library, Class, Window Title, Same as VI Name, Execution State, Description, LV Version, In Memory, Allow
Debugging, Auto Error Handling, Date Modified, Modified, Separate Compiled Code, Show FP when Called, Show FP when
Loaded, Suspend when Called, Preferred Exec System, Execution Priority, Revision Number, History Text, Protection, Code
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Size, Data Size, Front Panel Size, Block Diagram Size, Total Data Size, File Size, Code Complexity, Reentrant, Reentrancy
Type, Clones, Callers, Inline SubVI, Inline is Allowed, Transparency, Logging Path, Show Menu Bar, Run Time Menu, Monitor
and Scan Time. Turning off the display of a column does not prevent it from being searched or edited.

Search Options

Match Case selects if text filters are case-independent or case-sensitive. Editing in Match mode will use the same case
setting. Select Include Dependencies to include them in the results. Enable Include Targets to show cRIO and FPGA
targets. If a project is already loaded and this box is enabled the use File -> Reload Project to see the targets.

Edit Options

Save Change will automatically save the VI after each edit operation. Close Item will close each VI. If Save Change is off
and Close Item is on, LabVIEW will prompt for every VI to be saved or not. Trim Description will trim the whitespace from
both ends of the Description before editing the string. Use ‘\’ Codes will change the display of the Search Text and Edit
Text to display \ codes.

Sort Columns

The result columns are pre-arranged in the same order as the Columns to Display settings. For convenience, all the
columns may be sorted alphabetically by the displayed name of the column. Options include no sort, ascending order and
descending order.

Pagel4



VI Scripting

Scripting allows custom extension of the operation of the Property Inspector beyond the properties that can currently be
edited. In only a few minutes, a scripting VI could be written to search or edit other properties or perform more complex
edits. Leveraging the existing library of Quick Drop shortcuts provides a quick and easy capability of performing common
operations without writing any code.

Standard templates are provided to assist the creation of these scripts. The front panel must not be altered, since the
script is called dynamically. Save the modified script in any location and select it using the menu option. Then select all
the Vis to be edited and run the script. Any errors generated will be displayed by the Error Details dialog. Both selected
QuickDrop and VI scripts files are stored separately, allowing both to be used alternately. Itis possible to disable save and
close for the first scripts and enable both for the last script run to minimize revisions.

VI Script

Use the included template VI based on the standard VI Analyzer template to write custom operations. Pl will open the VI
before the script and optionally save and close it (based on settings dialog). If Update Selections on Failures is checked,
then only the Vis that return an array of Results Data will remain selected. This can be used to perform custom or complex
search criteria. The status bar in the center will display the number of failures and the selected items.

Hw Script Template.vit Template EI@
File Edit View Project Operate Tools Window Help Vi
B e[
VI Refnum Results Data

error out

m

status  code

< o

sS0urce
| -

Result Message

Project Inspector 12.vpraj/My Computer] ¢ [} 3

QD Script

Use the included template VI based on the standard Quick Drop template to write custom operations. If there are Quick
Drop shortcuts installed with LabVIEW, they can also be used. Alternatively, use the included link in the Help menu to
download pre-written QD scripts from the Quick Drop Community. Use the Quick Drop Configuration panel to set the
required options once for all Vls.

Pl will open the VI before the script and optionally save and close it (based on settings dialog).
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Error Details

If any errors are detected during the editing process, a dialog will list the VIs with the corresponding error codes and a
description of the errors. The total number of errors is also shown.

3 Edit Error Details [=2a]
Refresh selected items
Edlit Errors
VI Mame Error Description -
0 Errars Export ... ] | v d [al’§
Export...

The list of errors with the details shown can be exported to a spreadsheet file for additional analysis or corrective actions.

Other Errors

Other error dialogs include: Project file is newer than current LabVIEW version, Library file is newer than current LabVIEW

version, LVClass file is newer than current LabVIEW version, No selection, No columns are displayed, Not all items could be
deleted, Not all items could be opened and Not all elements could be run.
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New Features
Four unique features in Property Inspector are Global Exclusion™, Persistent Selection™, Compound Sorting™ and Sort by
Unsorted.

Global Exclusion™

This feature allows simple, one step elimination of object based on what parameters you need to exclude. The global
search includes all of the string parameters including Iltem Name, Item Path, Item Type, Description, History Text, and
Protection. Many times, a search is narrowed by just eliminating an entire category by using the exclusion.

Persistent Selection™

This revolutionary new feature maintains the selected items even after changing the object filter, search criteria or Sort
order. Imagine performing a search and selecting a range of objects. Then you realize that some object should be hidden,
like removing controls before editing the execution priority. After changing the settings to hide the controls, the remaining
selection remains. Then you prefer to sort the list by a different parameter before edit the objects. The items originally
selected are still selected, even if they are no longer sequential. Just imagine if Windows File Explorer worked this way!

Compound Sorting

When the project is first opened, the entire list is in the same order as the items in the project. Every time the results are
sorted the list is automatically sorted by the selected parameter, followed by the original order. When enabled, this
feature will sort by the selected parameter, followed by the previous order, and then by the original order. For example,
sort the entire list by date to see the oldest first, and then sort by item type. The list shows all the objects grouped by item
type, with the oldest item first in each group.

Sort by Unsorted

When the project is first opened, the entire list is in the same order as the items in the project. This is a great convenience
if both the Project Explorer and Property Inspector are both open. After several sort operations have been performed,
sometimes it is nice to go back and see the list in the original order. That is what Sort by Unsorted does. It returns the
results list back to the original, unsorted, ascending order.
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Impossible Features
Most of the features of Property Inspector are unusual because they are difficult to do in LabVIEW. Many of the features
are remarkable, because they are impossible in LabVIEW!

Callers

Many Vis are used repeatedly throughout the project. You can see the number of callers by selecting the VI in the project,
right-clicking and selecting Find -> Callers. To get the callers for all Vis, this process would have to be repeated for each VI.
Property Inspector displays the number of Callers and can sort this value to highlight the largest numbers.

Clones

When using pre-allocated, re-entrant clones each clone occupies its own memory space and since 2013 is assigned a
unique numeric code. Common questions might include how many clones are there? Which Vis have the most clones?
Although it is possible to count the clones by using the View -> Browse Relationships -> Reentrant Items menu, this is not
practical. LabVIEW cannot identify which VIs are reentrant or pre-allocated. You would have to open each VI and browse
3 levels of the menu to see how many clones there are. This may also require scrolling down over 10 pages to get the final
count of one VI. Property Inspector displays the number Clones and can sort this value for all Vls to highlight the largest
numbers.

Close Opened Windows

The options to close Vls include closing each VI directly, Close All (this project) and closing the project. What if you just
opened 25 block diagrams and want all 25 Vis closed? This process takes at least 25 steps if not 50 or more. When a group
of front panels or block diagrams is opened by Property Inspector, a single click can close all of those ViIs.

Date Modified

With the exception of the LLB Manager, LabVIEW cannot display the date last modified of any object in the project.
Property Inspector shows the date for all Vls, controls, libraries, classes, documents, LLBs, folders and most virtual folders.
Yes, P13 can display the date of the LLBs, folders and many of the virtual folders. If the virtual folder matches a name of an
existing folder at the same hierarchy location, that date is displayed.

Delete Selected Vls, even from LLBs

| don’t remember when LabVIEW had the option to delete a VI from the project while removing it from the disk, but it was
a very long time ago. LabVIEW can show the VI in Windows Explorer and separately remove the VI from the project. The
file still needs to be manually deleted using the Windows Explorer. What if the VI is stored in an LLB? Explore only shows
the LLB, where you have to open it, locate the file, delete the file and close the LLB manager. Property Inspector can
delete an unlimited number of VIs from multiple locations including multiple LLBs in a single operation.

Execution State

LabVIEW will only report a VI is broken if it is in memory and the Error List is displayed. The Error List window displays the
list of VIs in the top third of the window, does not count the VIs and is not multi-select. LabVIEW cannot report which Vis

are running or idle, unless each one is open and the run arrow is visible. Property Inspector displays the Execution States

of Idle, running, broken, invalid or run top-level for all Vis in the project.

Export Search Results

Found a set of problems, work items, changes or features that you need to document or share with another programmer?
Other than printing individual front panels or block diagrams, LabVIEW has never had a feature to print any part of the
project explorer, much less a specific search results or selected VI properties. Property Inspector will export the results
window exactly how it appears on screen with customizable columns, a specific search criterion and sorted by any
property to a tab-delimited spreadsheet file.
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Find all Dialog Windows

What if you need to modify all the popup dialog windows? How can you find all the user facing windows? Property
Inspector can find all Vis set to Show Window when Called is true. This search will show all dialog Vls.

Find and Prepend, Append, Remove or Replace All

LabVIEW has a very powerful search that will find text anywhere in the front panel, block diagram, tip strip, description and
history text. You may not believe this, but LabVIEW cannot remove the text that it found, much less the surrounding text.
In the Replace window, you must enter some text, or LabVIEW will not perform the replace or replace all operation. When
searching the description contains specific text, Property Inspector can (1) replace the text with new text, (2) remove the
specific text, (3) prepend new text on the original description, (4) append new text to the original description or (5) replace
the entire description with new text, not just the specific text that was found.

Find Anything but That
LabVIEW can only search for something to find. Because Property Inspector can search the entire project by 9 different
criteria, it can find all the VIs that exclude specific criteria (i.e. Description excludes written by).

Find Anything or Nothing
LabVIEW can only search for text in string or numeric values. Because Property Inspector can search each VI for a single VI
property, it can find all the VIs that have any value or no value (i.e. (Class is not blank or Description is blank).

Find, Find and Find Again
LabVIEW can only perform a single search and display results. Property Inspector can search within the previous results an
unlimited number of times. (i.e. LabVIEW Version < 19 and Execution State equals Bad and In Memory is False).

Find More or Less
LabVIEW can only search for text in string or numeric values. Because Property Inspector can search each VI for a single VI
property, it can find all the VIs that have a value more or less than a specified threshold (i.e. LabVIEW Version < 14).

Find True or False
LabVIEW can only search for text in string or numeric values. Because Property Inspector can search each VI for a single VI
property, it can find all the VIs that have a value of True or a value of False (i.e. Separate Compiled code is False).

Find Recent Changes

Every need to see a timeline of your changes or of everyone in your team? Want to find all those files you worked on last
week? Just synchronized with SCC and want to see the diagram of all changed VIs? Property Inspector can sort the entire
project by Date Modified to show the most recent changes first.

In Memory
LabVIEW keeps a record of which Vis are loaded into memory, but cannot show if a particular VI in the project is in
memory or not. Property Inspector cross-references each VI and control against the list of Vs in memory.

Inline Allowed

Setting a pre-allocated, re-entrant VI to inline can improve performance by eliminating the overhead of calling the subVI.
LabVIEW internally knows which Vis can and cannot be changed to inline, but will not tell you. Only by selecting the inline
check box will you know if there is an error preventing inlining. Property Inspector displays the state of this eligibility so
you can quickly search for all Vis that qualify and even set them all at once.

Open Block Diagrams
LabVIEW has had the capability to show you the block diagram directly by holding control and double clicking on the SubVI
in the top diagram since the early days. But in the process the front panel is also displayed. What if you wanted to
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compare 20 or more block diagrams? Property Inspector will open an unlimited number of block diagrams while
simultaneously hiding the front panels.

QuickDrop on Steroids

Since 2009, LabVIEW has built upon QuickDrop to create an efficient and extensible way to speed development. Many
developers have written plugins to add powerful editing operations in just two steps. My favorite is MoveToOrigin. This
QD plugin performs 4 diagram cleanup steps at once. There is no reason not to run this script on every VI in your project.
But how? Property Inspector allows any QuickDrop script to run on all selected VIs in the project.

Scan Time

Many LabVIEW users want to know why it takes so long to load their project. What is causing the delay? Are there specific
items in the project that slow or freeze the process? Property Inspector now records the time required to scan all the
properties of each object. Results clearly show that it takes considerably longer if the VI is in an older LabVIEW Version,
broken or missing SubViIs.

Sort by Number

LabVIEW recently added the capability to sort the project find results by one of the 3 visible columns, but only sorts by text
(i.e. vi12 before vi2). Property Inspector can sort VIs by numeric data value. This includes fields like Code Size, Data Size,
File Size, Code Complexity, Revision Number, LabVIEW Version, Callers or Clones. Sorting all Vis by Data Size quickly
identifies all VIs that have large arrays stored in the diagram or front panel.

Suspend when Called
How many times have you compiled an executable and then realized that one of the Vs had suspend when called still
enabled? Property inspector can find all these VI by searching for Suspend When Called is True, and clear them all at once.

View in Project

LabVIEW has had the capability to find the open VI in the project for many years. But what if you need to highlight several
or even a hundred Vis in the project? After performing a search and/or a sort operation, just select as many Vis as desired
and View in Project will highlight them all.

View Specific Item Types

The LabVIEW project window is missing a basic function to hide project items by type. Imagine you need to see just
controls, standard VIs, typedefs, strict-typedefs, classes, libraries or variables. What if you only need to hide images,
documents, property nodes or global variables? Property Inspector scans every item in the Project Explorer window and
will display only the items selected in 20 different categories!
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Search Examples

Here are several useful examples of Property Inspector operations. The Property Inspector settings are expressed exactly
as it appears on the screen. Some examples show the edit operation with sample edit text and notes in parenthesis.

All of these examples can be found in the Help menu under Search Examples.

1. Description Starts With Use this template to, Remove

2. Description Is Blank/0O/False, Replace (Description of each VI) (then press Next to advance to the next VI)
3. Allow Debugging Not Blank/True, Remove (remove will disable Allow Debugging)

4. Execution State Equals Bad

5. Data Size Greater Than 100K

6. VI Version Less Than 12

7. In Memory Is Blank/0O/False (locates all Vs not in memory)

8. Auto Error Handling Not Blank/True, Remove

9. Is Reentrant Not Blank/True

10. Reentrancy Type Contains Pre, Replace S (Search In the results of example 9 to narrow the results)
11. Date Modified Less Than 2010
12. Separate Comp. Code Is Blank/0/False, Replace T

Support Resources
For support with Property Inspector, use the following resources:

Website: http://support.abcdef.biz
Phone: 1-800-422-1523

Email: support@abcdef.biz

View quick demonstration Videos on the ABCDEF YouTube Channel
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